PracticePanther Update
Incident Report for PracticePanther
Resolved
The update completed successfully.
Posted Dec 06, 2017 - 10:58 EST
Monitoring
We are currently releasing an update to PracticePanther to resolve an issue with our latest release which may cause slow response times for the next 5 minutes. We apologize for the inconvenience, and are monitoring the data-center for any irregularities.
Posted Dec 06, 2017 - 10:51 EST