PracticePanther Update
Incident Report for PracticePanther
Resolved
The update completed successfully.
Posted Aug 12, 2017 - 09:39 EDT
Monitoring
We are currently pushing an update to PracticePanther which may cause a downtime of up to 10 minutes.
Posted Aug 12, 2017 - 09:30 EDT