Some Users May Be Experiencing Issues Logging Into Box
Incident Report for PracticePanther
Resolved
This incident has been resolved.
Posted Oct 13, 2017 - 22:53 EDT
Monitoring
Box.com is currently experiencing issues that are not related to PracticePanther, but may affect some PracticePanther customers.

For more information, you can visit Box's status page for real time updates: https://status.box.com
Posted Oct 13, 2017 - 16:39 EDT