App is currently experiencing an outage
Incident Report for PracticePanther
Resolved
This incident is resolved.
Posted Nov 16, 2018 - 17:04 EST
Monitoring
We experienced a temporary outage affecting app.practicepanther.com. We are currently monitoring to ensure its stability.
Posted Nov 16, 2018 - 17:03 EST
This incident affected: PracticePanther.