PracticePanther Update
Incident Report for PracticePanther
Resolved
The update completed successfully! We hope you enjoy our new flat fees billing feature. You can learn more about what we're up to at https://www.practicepanther.com/updates
Posted Aug 25, 2018 - 19:18 EDT
Monitoring
We are releasing an update to PracticePanther to add new features. This may affect performance for some of our users.
Posted Aug 25, 2018 - 19:16 EDT
This incident affected: PracticePanther.