System Maintenance
Incident Report for PracticePanther
Resolved
Our engineers completed the work successfully.
Posted Aug 04, 2018 - 12:37 EDT
Identified
We are performing routine maintenance work on our servers which can cause PracticePanther to be inaccessible for some of our users.
Posted Aug 04, 2018 - 12:36 EDT
This incident affected: PracticePanther.