PracticePanther Update
Incident Report for PracticePanther
Resolved
The update completed successfully.
Posted Apr 05, 2018 - 23:21 EDT
Monitoring
We are currently pushing an update which may cause some connectivity issues. We are monitoring the update and expect the update to complete within the next 5 minutes.
Posted Apr 05, 2018 - 23:16 EDT